QuarkXPress 7 (Mac OS X) druckt nicht auf OKI-Drucker

QuarkXPress 7.0.1 aufwärts weigert sich auf Mac OS X gerne, auf OKI-Drucker zu drucken, vor allem auf Farblaserdrucker. Die Jobs erscheinen kurz in der Warteschlange und verschwinden dann kommentarlos.

Der Fehler wird offenbar durch eine „custom filter“ Funktion des Druckertreibers verursacht, der ab Quark 7.0.1 Probleme verursacht, seitdem Quark den neuen „CUPS printing path“ verwendet.

OKI hat zu diesem Thema eine Technote (man suche auf my.okidata.com nach Dokument #3637), and empfiehlt den Einsatz neuerer PPDs. Leider führt auch das nicht immer zum Erfolg.

Was aber hilft, ist die PPD zu Fuß zu bearbeiten. Die PPD für den C9600 findet man z. B. hier:

/Library/Printers/PPDs/Contents/Resources/en.lproj/OKI C9600

Man öffne also diese Datei mit einem Texteditor und kommentiere die Zeilen aus, die mit „*cups“ beginnen, indem man am Zeilenanfang ein „%“ Zeichen einfügt:

*%cupsFilter: „application/vnd.cups-postscript … (usw.)

Die geänderte PPD legt man am besten an einen anderen Ort, damit sie durch Updates nicht versehentlich überschrieben wird. Damit die Änderung aktiv wird, muß man dann noch in der Druckerliste (Drucker-Dienstprogramm) den Drucker löschen und neu „hinzufügen“. Dabei wählt man „Drucken mit: Andere…“ und lädt die überarbeitete PPD.

Anschließend funktionieren zwar gewisse OKI-spezifische Funktionen nicht mehr (hat wohl was mit Abrechnungsfunktionen und Seitenzählern zu tun), aber dafür druckt Quark wieder.

Kommentieren